Live chat unavailable
Incident Report for Orlo
Resolved
This incident is now resolved, thank you for your patience whilst we looked into this.
Posted Mar 15, 2023 - 20:45 UTC
Investigating
We are experiencing intermittent issues with our live chat. Whilst we are investigating this our Live chat will be offline so please contact support@orlo.tech for any queries.
Posted Mar 15, 2023 - 16:29 UTC
This incident affected: Live Chat.