Delay in the inbox and outbox
Incident Report for Orlo
Resolved
This delay has now been resolved. Our apologies for any inconvenience caused.
Posted Sep 22, 2022 - 17:32 UTC
Investigating
We are currently aware of a delay in the inbox and outbox and are investigating the cause. Update to follow.
Posted Sep 22, 2022 - 17:02 UTC